I can't cancel any pending transactions

And after changing my nonce to 0, and confirming it to cancel the previous transaction, the nonce changed itself to a new nonce. Now I have more than 6 transactions pending and am sick and tired

I am experiencing issues where i cant overwrite the nonce 0 transaction. Can i get a hand with canceling it? I have 2 wallets that have stuck transactions.

App Ver. : 1.10.2
Wallet 1: 0x3Bd0748340e6b5CC83fCC175e7a75553a20EF37F
Wallet 2: 0xAa5a6b06d8bb7BE22d151b4Aea2215d08441C44F

Please I have the same issue on two of my wallets. I’ve had transaction pending on the both of them since last week. Please Kindly help me.

Wallet ID 1 - 0x01078BC54384574bD9C47A0C4B3AB42688849eCF

Wallet ID 2 - 0x461381988a9Ccd461e1dcD12a9Ba7d2Ba2660de7

Trust Wallet Version - 1.10.2

Multi-coin wallet

I’m experiencing almost same challenge, pending transactions for two days now. Please help

For those having issues changing the nonce to cancel a transaction, our devs will release a fix to address the issue.

Please I still need help. One of my two wallets that had the transaction pending has finally gone through but the other wallet is still pending. I have even tried sending 0eth and that one too is pending. This is now above one week. Please help me.

Wallet ID: 0x461381988a9Ccd461e1dcD12a9Ba7d2Ba2660de7

An update was already released, please install that and make sure to follow the instructions stated here:

You need to send 0 ETH and make sure to change nonce to 0.
That is the oldest pending transaction showing:

1 Like

I am not able to change the nonce value.

Hi, i went through the guide with 3 ways to cancel the transaction and decided to go with the second method. It is to send yourself 0 ETH. It says to change my nonce value of new transaction to the nonce of pending transaction. But when I change it, and tap on Save, the app redirects me to confirm page, but the nonce doesn’t actually change.

1 Like

An update will be released to address this.

My transactions have been posting for hours. Please advise.

My transaction hash: 0x66ac168f6e47807f7de907f0d914e1cefbf3be5390c3078cbb69ffc37b1184d1

Looks like this already completed.

This is my wallet address… I also upgraded to the latest version…

My erc 20 token has been stuck on pending for almost a month now

You have 2 pending transactions with very low fees.

Follow this guide closely to cancel both first before you create a new one.

I’ve tried canceling my pending transaction twice but it hasn’t been sent up till now. How do I go about fixing this?

Can you try the suggestion above?

I have been facing this same issue for 5 days, all my transactions are failed. I followed the methods of creating a transaction with the same oldest nounce number and sending 0 eth to myself but it didn’t work. I just installed it 5 days ago so its the latest version. Pls help!!!
This is my wallet address

There seems to be an older transaction that is yet to be processed or cancelled.
You need to set the same nonce as this one. This is nonce 0.
Once this gets cancelled the other pending transactions will get processed if their gas fees meet the minimum bids.

After installing trust wallet and importing my wallet… I can’t find the pending transactions…

What is the ETH address that you have on the app?
Can you check it here https://etherscan.io and see if there is any pending transaction.