Rejected transaction

A few days ago, I sent from FTX 2 different Solana Coins (Star Atlas & Step Finance) to my Trust Wallet. It worked without any problems. I can see my funds now in my Trust Wallet. However, today I tried to send them back to FTX. Without any success. I tried it twice, but the transaction was denied. I can’t find any information on Solscan as well. Can somebody please help me with my issue? This is the transaction ID: 5cYZr95Kezi2Jaj1isgpbNUF2MoKUVHtHUwhp2BZReYdErufLuRNQTbC8njjs5xddeQf9zkYntqhwwRUW1CBnTZH

Hello @Zerebralyoga To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

Is there maybe a Network problem with Solana? I can see all my Solana Tokens on Solscan.

Hi alan47, It was a Network Problem. I fixed it myself. Thank you anyway.