Transaction always pending and then failed

Hello, I have enough bsc for the gas fee, but I cant swap or send or buy any coin on my BEP-20 network. I cant send my busd bep20 to another address. First, its pending transaction, I waited for 10 mins or more, then its failed. Its always like this no matter how many times i tried. When i tried to click the details on bsc scan, it says “unable to locate the txnhash”

My trust wallet is 7.10 version which is the latest one, I tried to disconnect and reconnect, and still I cant do anything on my BEP-20 network (literally every transactions, i cant send / swap / buy any coin)

Here is my tx transaction address

When i look at advanced settings, the transaction data (optional) 68 bytes, is already filled with unknown address, which is the normal wallet supposed to be 0x. Is there anything you can do to fix my issue here? I contact trust wallet [email protected] but i don’t get any response

@cuankaya2k22 To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

Still not working but thanks though for the help. I tried another way, it works now.