Transfered token didn't arrived

Hi. Yesterday I sent Vetchain tokens to my trust wallet, but there is nothing visible in my wallet. Can anyone help me?
It was my first, test, transfer.
Thank you.
Version of my walket: 5.29


Hello @Lubomir
Your tokens are in your wallet and you only need to add it manually as a custom token using these details
Network: Smartchain
Contract: 0x6FDcdfef7c496407cCb0cEC90f9C5Aaa1Cc8D888
Decimals: 18

Hi Jenny,
Thank you for your fast response. I’ve added it manually, but still not there.

@Lubomir Can you provide a screenshot of your wallet?

@Lubomir Your VET token is in your wallet and on the BEP20 network as you can see here

Can you try reimporting your wallet then add the VET again manually using the guide in my reply above.

What do you mean by “reimporting”? I have tried to reinstal the app in my phone, but nothing has changed.

Above you can see a new screen from my trust wallet.
Also I have tried to create a new multicoin wallet/ multicoin wallet 2

@Lubomir To better assist, please send the following information:

Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here.)

Is it the right one. You mean from wechain token?

@Lubomir It seems you sent your tokens to your VET address but on the BEP20 network.
The address you just sent in the screenshot is different from your original post.
You would need to use this guide to get your Vechain private key then import as a BEP20 wallet using that private key.

Finally, got it. Thanks a lot for your help.
I hope, it won’t be always so complicated to get my tokens.