Trust wallet tries to deduct ETH instead of MATIC (Wallet connect)

I have tried to use polycat.finance to swap MATIC, from my trust wallet, for some other coin.

Wallet connect sends me back into trust wallet to approve the transaction (I click on the “mobile” function to do this on my phone.)

Back in trust wallet, it asks me to approve the transaction but for ETH, which I don’t have, not MATIC.

The amount in ETH, if I had it, would be 1.5 million dollars.

Did I miss a setting somewhere on trust wallet?

1 Like

The other coin is PAW, which is the polychain network, like MATIC.

I am asked to approve the transfer of ETH, instead of the MATIC which I wanted to sell.

I just tried to upload the screenshot of the transaction but I am not allowed.

Hello @BigKnockers To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

There is the problem.

Has anyone else successfully sent MATIC from their trust wallet? I wonder if it works, or whether the wallet is confused about matic.

@BigKnockers probably, you connected to a wrong network (open the DApp again and screenshot, then send it here). Or could be the problem with DApp itself.