I am unable to unstake my Tron even after the 3 days limit

I staked 6556 Tron in my Trust wallet on March 4. Now I cannot unstake them even after the 3 days limit. My Tron address is TQqw4v31bmHmg6di3XVBP8zniJW33N7XVx. The transaction hash is 77b3cf3436b6aeffcd2640bccb406eddab3cac4c7bf62b1e61033b0a2ccc20d1


I checked the Tron explorer and saw this:

You are right, it is more than 3 days already.
Can you follow this guide to unstake the tokens:

If you still need assistance, can you provide us the following information:

  1. Trust Wallet app version
  2. Screenshots of the TRX wallet.
1 Like

My Trust Wallet app version is 1.7.183. When I try to unstake Tron it shows not available on screen.

Sorry. I couldn’t upload more than one screenshot in one post as I am a new user. So here is the second screenshot.

Thanks for all the information.
Please try the following steps.
I noticed that the tokens are frozen but it was not used for voting.
That may be causing the issues.

You may need to stake the tokens again for 3 days and have it complete the cycle properly.
At the stake amount screen here are your choices:
1.If you are not planning to move the tokens you can input the entire balance manually (recommended)
2. You can move the available balance on the wallet and then to stake just the current frozen amount which is 6556.952472 TRX

Let me know if you are able to do the steps above.

Thank you for your quick response. I have successfully staked the current frozen amount once again which is 6556 TRX. I have input the entire balace manually. Will wait for 3 days again. If the problem still persists I will contact you again. I loved the quick response from Trust Wallet team. Keep up the good work.


Hi. My trx wallet is frozen. Even after 3 days it is still frozen. I cannot unstake them
What should i do ?

1 Like

Your issue might be similar with the one above.
Please do the Stake command again, and manually input the amount of Frozen TRX.
Afterwards, do the Unstake command.
If you still need assistance, please provide the following:

  1. Trust Wallet app version
  2. TRX address

Hello. I am having the same issue with my Tron Wallet for staking ang claiming rewards. I tried following the steps above but it is still the same. hope you can help …

1 Like

What is your TRX address so that we can investigate further?


If I stake how do I vote


Available:0 trx
Stake: 1132 trx
Frezeed: 1132,41709
Rewards: 0,73834

i tried to stake my trons, after 3 days i couldnt unstake it. And i read forum, they were writing stake it again and i will be available for unstake but still same. What can i do for it. Pls answer


Please get some trx to pay the network fee follow this guide: How to Unstake TRON (TRX) Tokens

Its about 22 days that i staked my trons and i cant claim my rewards im gettin mad

Hi @Cna,

To better assist, can you provide us the following information:

  1. Trust Wallet app version (go to settings and press “About”)
  2. Crypto address
  3. Screenshots of the wallet (errors, if any)

Good day, I staked 466 trx on the 18th of September but I am unable unstake it since then. Please I need your assistance.
The version of my app is 1.13.1

Hi, please update your wallet to the latest version and try again.

– Locking thread since this is an old one. Please create another one if you require more assistance.

1 Like