NEAR Protocol transaction status succeeded, but the balance is not updated

so I managed recover my NEARs, I tried this steps:
Currently I’m using iPhone 8 plus, iOS 14.4.2 and TrustWallet 5.21
1- I Re-Imported wallet: Didn’t work :x:
2- I Reinstalled Trust Wallet: Didn’t work :x:
3- I Installed TrustWallet on another iPhone (model XS and iOS version was 14.4) and imported my wallet: YEAH I saw my NEARs on my friend’s iPhone :white_check_mark:
4- I Installed TrustWallet on three other cellphone, Two android and a iPad: it did not work :x: :flushed:
5- Finally I referred two my friend iPhone (Step 3) and transferred my NEARs to binanace and again tranfser back to my wallet with BEP2 network :white_check_mark:

I hope this experience help TrustWallet users and please debug it

1 Like

They didn’t debug it. I have same issue with Near protocol. They haven’t any new solution except reinstall and reimporat wallet. that useless.
what should I do??

Hello @aznawa To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)


  1. my wallet address is : bd0cf1ec508dda68b45ab0347f6aa13e8d719bcce892a8fb0a97973722a3af2c

  2. TxID: 2fuaqnokrQuD6HRgrFDpTou7L9VRVsapKdYg4s5tMNqm

4. Itransfer my Near crypto form binance to trustwallet. the wallet alert successful crypto recieved : but the balance show zero :

also I uninstall and reinstall my wallet multiple times and install on another android device. but the result didn’t change.

@aznawa try to use VPN and refresh your wallet, if the problem persists let us know.

Finally my problem solved. Thanx a lot.
First I used vpn with europe and then us servers. But the result didn’t changed at all.
Then I used openvpn server on Germany and next Singapore. Finally openvpn + Singapore works fine. And my balance shows itself.

For those who have same issue I recomment try different service of vpn with multiple servers. This solution works.
Thank you Alan47👍

Great! Glad to know that. If you have further inquiries, feel free to message us. Stay SAFU!