Tired to swap token for eth, smart contact call created, fee taken, no transfer took place, now can not swap or send token at all

This was not my first time swapping this token. I swapped it to buy it then swapped it a 2nd time when I bought the dip… Usually when I want to swap a token I get to a page that explains the gas fees. With Saitama it won’t get to that page, it just shows a blank pop up box with “OK” at the bottom. If I change Saitama to A different ERC 20 token it will bring me to the swap page where It tells me I need more gas fees.

Why can’t I swap SAITAMA after approving it? It’s stuck. I can swap anything else but SAITAMA. Doesn’t even let me get to the page with the gas fees?

Here’s an example of what I’m experiencing …
When I try to swap SAITAMA for ETH I get the blank pop up. When I try to swap ETH for KEEP or even ETH for SAITAMA it works. Or I at least get to the page where it list the gas fees

I am having the exact same problem, only difference is that I swapped STMX for ETH.

1 Like

Yea it’s been almost a week, nothing works. Did you try to send it to a different exchange instead of swapping?

Not yet. Waiting for gas prices to settle down before I do that. I will let you know if that works. Have you tried it yet?

I tried buying a coin I did everything right but the transaction has been pending for over an hour

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

I’m having the same problem tired to swap dai to eth it charged me a fee but didn’t swap coins

Trying to figure out all this is so confusing
Especially when is the system at fault :confused:

When swapping tokens for the first time, you have to approve it first to be spendable. And, that is what you did just now.

Since you are done approving the token, you need to enter the amount that you want to exchange then press the swap button.

All in all, you will confirm two transactions: approve and swap

NB: Both token approval and swapping transactions needs gas fees.

Read more: What is Token Approval?

Please see my response above your comment.
You approved the token for swap, now you just need to follow the same process to swap it.

Please read this:

So why they didn’t say this before
Man sorry but how do I get my refund

When I say it’s the system fault I mean I send my dai from Coinbase to trust wallet after hitting the BSC not eth copied the receiving address for BEP20 0x1af3f329e8be154074d8769d1ffa4ee058b1dbc3
Receiving address
But it went to a different dai in eth which I didn’t send to I copied the one in Binance-peg dai token
Sent and you people messed up and add it to the wrong dai
Can this be fix my trust wallet being it trust wallet fault I going through this
And honestly you people need to do better this is people money you are playing games with.
How can you send to one address and it goes ina different one :thinking:

The same empty pop up window with “OK” appears for me after the STMX was approved for swap and first gas fee was charged when trying to swap. There’s no way that this is what is supposed to happen. The app is broken, please fix it. Also, it won’t let me upload my screenshot.

1 Like

What do you mean friend I validate my wallet can you explain so you say you have the same problem but is fixed
What problem do you have and same as me how did you fix it

Your DAI on coinbase was on the ERC20 network;
Note that ERC20 and BEP20 addresses are the same therefore sending your DAI to your Trust wallet would be on the ERC20 network.

Mine has been stuck like that for weeks. I re downloaded the wallet and it still doesn’t work. These people act like they don’t know what I’m talking about when a lot of people are having the same problem.

Man this is not kool I was trying to send my dai to Binance-peg maybe they should have this info available before people send there cash to get stuck