Walletconnect to Pancakeswap issue

Hi, I am getting these errors when I try to connect my trustwallet with pancakeswap. I have tried Safari, Google Chrome and Firefox. I am using iOS. I had no issues prior.

I will get “Authorization Error”, “No provider support” and no wallets appear in walletconnect with " something went wrong" when I click connect on pancakeswap.

Please help, thanks


Hello @solotomato what is your app version?
Also check this guide on how to connect PancakeSwap: WalletConnect Mobile Linking with Trust Wallet

1 Like

hi Alan, my app version is 6.3 (635). i’ve read the guide as well, not working still… thanks


Got the exact same problem. Last night it worked great.
Hope you can fix it Alan.

1 Like

I am having the same issue

App is up to date, using iOS. I have tried to Safari, Chrome but getting the same error.

“Something went wrong”

I have also used QR code to connect with Pancake but App never acknowledges the connection or doesn’t show a connection pop up.

Please help.


Am getting same and wallet is not connecting in Poocoin or pancakeswap or any other exchange’s… whats goin on… am missing the bull run… its been a while now do something Team… asap…


Hi Alan,

I am also facing the same problem. Version 6.3 (635) as well. Looks like WalletConnect just can’t find Trust wallet on my device.

I wasn’t having issues the other day though. Curious to whether it’s potentially recent security settings with iOS that’s preventing Wallet Connect in finding Trust?

Thank you.


I am also experiencing this issue :frowning: I have tried clearing my cache/cookies and history, but it still comes up saying there was a problem and then saying there was a verification error. Ahhhh :frowning:

1 Like

This issue is to big, can someone please reply with the solution. Its been a day will facing this issue by not connecting to wallet.
Version 6.3


1 Like

I’m having same issue I do know yesterday I had small delays for connecting but today after I downloaded new update for trust wallet 6.3 now I can not connect. I also have tried everything n nothing works. Please help. Grace

1 Like

It’s working for me now. So hopefully it works for everyone.

Enjoy trading :slight_smile:

weird mine says connecting… but then it goes away and doesn’t ask me to go back to my browser to check

1 Like

Hello all, it is the issue with WalletConnect, their servers were down: https://twitter.com/WalletConnect/status/1425413115152306177?s=19

I think will be fixed soon.

Same issue here. Using Trust Wallet version 6.3 connecting to PancakeSwap. I scan the QR code, it shows “WalletConnect Connecting…” then it just goes away and I never get the confirmation screen. It’s definitely not a PancakeSwap issue because the same thing happens with Uniswap. I also tried using Safari, Chrome and Firefox, same issue on all of them. I also tried taking a screenshot of the QR code and importing it from the WalletConnect screen, same thing.

Please advise.

Have a same isue for ios version 6.4 (643). Wallectconnect not connected crudeoil.finance.
“An unknown error occurred”

I have the same issue with btcst dapp. Can not connect to trust wallet ?!

Hi, I am able to connect pancakeswap with TW but when I tried to make trades, I get redirected back to TW with “WalletConnect. Connecting, it may take a few minutes.” And nothing ever happens?!

Hello @Shermanomam make sure you have latest app version. Here’s a guide on how to connect PancakeSwap: Using WalletConnect to Access PancakeSwap

1 Like

I have a problem ,i can not connect my trust wallet to pancake p.c version where every time i try to connect my trust wallet screen show invalid link statement ,i can not connect my wallet with pancake .

Hello @syedbesharat, there is a guide at the beginning of this post.
Check that to see how to use wallet connect with pancakeswap.