Xrp not in trust wallet

Bought xrp on pancakeswap it shows up in BscScan but there are no tokens in my trustwallet. Im a new bee. Bought safemoon prier to xrp and it is in trust wallet

Same! I ordered through moonpay & simplex 7 days ago, still not in my wallet!

1 Like

Hello, @Donshome please tap on top right corner and searchXRP then switch on XRP BEP20 manually. This guide can help too: How to Add or Remove a Coin


@KaneU13 you can contact them and open ticket here: List of Cryptocurrency Providers

1 Like

Thanks, the transaction receipts are there showing as received but the coins are not in my wallet

I am having the same issue. I purchased XRP by swapping with Smart Chain on pancake swap, but my XRP assets are not showing up in my wallet. BSC scan is showing the transaction went through. I need help please, can anyone assist me with this issue? How can I transfer my XRP funds to my wallet?

I have never used simplex as a third party financial institution, I would recommend that you submit a ticket to receive better guidance. Or you can try this, go to BscScan and copy the TO address you forwarded your assets to and paste it in the search bar in your trust wallet after you click the button in the upper right hand corner. Let me know if this helps. I wish you the best of luck!

@Donshome, copy the TO address you forwarded your coins to in BscScan and paste it on the search bar in your trust wallet after you click the upper right hand corner. After that, you should see your coin pop up, activate it and your funds should populate in your wallet. It worked for me, let me know if this works for you.


I have sent XRP from Binance to my trust wallet one day ago but it is still not showing in my trust wallet. However I received an email from Binance saying that the withdrawal was successful. I used the correct address. Any guidance?


1 Like

Hi @Ibz To better assist, can you provide us the following information:

Trust Wallet app version

Crypto address

Transaction ID (if you have any)

Details about your issue

Screenshots of the wallet (errors, if any

Trust Wallet app version: 1.28.8

Crypto address:
You’ve successfully withdrawn 20.00000000 XRP to the address
Your withdrawal address is rMKAGpXLqHKkPQaaKPH1tUc6hrtd2Zr2zh,txid is 67D864D641990804D69C5DFA45D26333763B34A1DDA96181A41C97940C65BD4B

Transaction ID (if you have any)

Details about your issue: Transferred XRP from Binance to Trust Wallet. Binance says withdrawed successfully, correct address used but XRP not showing in Trust Wallet.


1 Like

Would anyone know why zilliqa, Matic, and xrp pops up as unavailable when trying to purchase on trust wallet ? Please and thank you

1 Like

@Ibz There is a 20 XRP fee required in order to activate an XRP wallet. This is set by the XRP network and not by the app. read more: How to Create and Activate your XRP Wallet

1 Like

Has the same issue here … did you get a solution ? I am waiting and donno what to do?!