-0 Eth Smart Contract Call Result


I keep having issues with trust wallet and Uniswap. If I initiate a swap XXXX to ETH, I get a confirmation message on uniswap (everything looks good), but when TrustWallet requests confirmation all it shows is
-0 ETH
From: Main Wallet 0xCxxxx
Network Fee: $x.xx

I tried “send” the swap once, and ended up doing nothing and losing ETH fees.

For example:
I tried to swap Octo to ETH a while back.

What am I doing wrong here?

Thank you for your help!


Hi @spubby9999,

Please read my response to this situation:

1 Like

Thanks, I understand the requirement to authorize a smart contract for swap.

I don’t understand how to swap my ERC20 token (Octo for example) using DEX->SWAP method described.

I can’t see it on the list, nor can I enter a smart contract into the search field.


The response that I mentioned was an answer as to why your Otco was not swapped to ETH.

Octo is not listed on our DEX->SWAP. You can continue in using Uniswap.

I’m sorry I don’t understand how they are related.

I used Uniswap with TrustWallet-> WalletConnect. Everything is connected.
Created a swap; 1 OCTO to ETH - received confirmation of correct info on Uniswap Dapp.

The final confirmation message sent to TrustWallet says -0 ETH + Fees every time.

I even looked through youtube and found this: How To Use Uniswap With Trust Wallet | Uniswap Decentralized - YouTube
It is same procedure I did.

Please provide me the following information:

  • Go to Uniswap, enter the amount of OCTO that you want to swap to ETH, take a screenshot, and attach it here.
  • The transaction link or hash of the 0 ETH tx w/ fees

I made some current screenshots of Uniswap vs Trustwallet.

As stated in my response the was linked earlier…

Q - I already pressed swap yet I was charged with network fees and nothing was swapped!? Help!

When swapping tokens for the FIRST TIME, you have to approve it first to be spendable. And, that is what you did just now. So, in order to swap it, you have to enter the number of tokens that you want to swap then press the “Swap” button.

You have to press the swap button again and confirm the swap. The 0 ETH tx was an approval for swapping OCTO to ETH. Thus, your OCTO is not yet swapped.

Understood. I will try again when fees aren’t disgusting. Thanks for help.

1 Like