Account hasn’t been opened yet - from Binance to Trust Wallet

I posted this question on the Nano form and they directed me here.

I downloaded the Trust app yesterday from the App Store - so this was definitely done using the current app version. Here is a detailed description of the issue.

I am brand new to crypto investing/collecting and I don’t have familiarity with a lot of the terms or acronyms people are throwing around - so please keep that in mind if you reply to try and help me.

  1. I have had a Binance account for a couple of months and have bought a few different currencies including Nano.

  2. Today I installed the Trust Wallet on my iOS device and created a multi-currency wallet.

  3. As a test, I tried to withdraw 16.49 Nano from my Binance account. To do this, in the Trust app, I added Nano to my wallet and chose “Receive”. I then copied the receive address. In Binance, I pasted the address in. The network showed Nano and was grayed out so it couldn’t be changed. I clicked Withdraw and then did other stuff for an hour. After an hour, I checked my Trust Wallet and it was still empty.

  4. I went back to Binance and the transaction said Processing (0/1). I checked Explorer and see that:

  • There is a TXID.
  • A send notice saying that the Block is confirmed on the network
  1. The block is:

  2. My receive address is:

When I click on the receive address I see the message:

While the account address is valid, no blocks have been published to its chain yet. If NANO has been sent to this account, it still needs to publish a corresponding block to pocket the funds.

This message makes me think that I need to actively do something to accept the transfer. Is that true? Do I? It has been over 2 hours since the transfer was sent? What could be wrong? Is there anything I need to do within the wallet to receive it? Why is it taking so long?

  1. After an hour and a half, I tried sending 100 Dogecoin from Binance to the same Trust multi-wallet. The Dogecoing transfer was successful in less than 2 minutes. (So I know the Trust wallet itself is working)

Is there anything else I can post that will help troubleshoot or resolve this problem ?

1 Like

Your transaction is still pending will be credited once confirmed or contact Binance for support.

The only reason that Binance is still showing it as “pending” is because the “Receive block” has not been posted by the wallet.

I’ve been told that this is not a Nano problem or a Binance problem. It’s an issue with the Trust wallet not seeing the transaction, receiving the funds - and posting the receive block.

After looking at the Nano explorer, what is it that makes you think the problem is on the Binance side of the transaction?

1 Like

Okay - so a few minutes ago when I opened the Trust app for the 10th time today, the Nano appeared. A few seconds after it appeared, I got an alert from Binance saying that the withdrawal had just been claimed.

Like all the other people who have opened tickets for this issue, I haven’t been given any explanation for the delay - but shortly after I posted my address and the block - it mysteriously appeared “on its own”.

It almost seems like someone is seeing the posts and then fixing things on the back end without claiming credit for their work or admitting there was a problem. I dunno if it was someone at Nano or someone here at Trust - but thank you for fixing my transfer - and I hope you are able to find and fix the root cause soon so nobody else experiences the same problem.