ADA staking has been pending for over a month

My Cardano (ADA) staking has been pending stage for a month now. It won’t let me cancel the transaction. How can I fix this transaction?


@Mfera42 Please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, then attach it here)

  2. Crypto wallet address (press the receive icon near the send button, copy and paste it here in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)


Hello @Tobi Do you know if the issue with ADA (cardamon) still persist? The balance on my wallet still showing zero, and I haven’t received the transfer that I made from my Deadalus wallet since Friday, Just need to know if the team is still working to get it solved so I can stay calm, thank you very much!

This is the hash of the transaction:

Thank you Diego


@dsalgara Seems the transaction has been confirmed already


Yes @Tobi Indeed, the thing is that my wallet in my app shows balance Zero and no history of the transaction is showing on my wallet, and I have wrote to support several times and haven’t get and answer from them, Im really worried because I never got the transfer, I have checked the transaction and the address is correct, everything seems to be correct but just not showing the funds on my wallet.

App Version: 10.4 (846)

Wallet Address: addr1q9v24h8fhecka7f7y3jg8qed5r0anv9n8av84ccqk66sgd3nzsp5kweyl48jpkmqu7eezpnytrzlnnk60v72xsjnwsysxwkcvl


@dsalgara There isn’t a need to worry since you can see your funds on the blockchain.
If the need be, you can submit a support ticket here and wait for a response via mail:

1 Like

I have submitted 6 tickets already with no answer, is it normal not to have shown my funds in my wallet, prob a node error or a glitch on the app or an issue with the carnage network? Just want to be calm @Tobi

Thanks for your help Tobi!!!


@dsalgara It’s best to submit just one ticket and keep checking your mail for a response.
Submitting multiple tickets just keeps pushing you downwards as there are other tickets also.
Please don’t open more tickets.
You’d need to be patient.


Thank you very Much Tobi, will do, I’ll just wait for the response, thank you very Much, best!


@Tobi Im just here to thank you for the helo you provided 3 days ago, I waited as you stated and I got a response, my Issue has been solved via support and I have my funds already!!! Thanks for your help!!!


Okay, Are you tobi24 on telegram? My staking transaction shows it failed but now I’m showing a balance of 0 for my ADA


@Mfera42 That is not me!!! It’s an impersonator, I will never contact you privately on telegram or anywhere else.

1 Like

Is it necessary to have a minimum amount of ADA available if you want to Unstake the ADA again?

Having staked all ADA in my wallet, it seems that unstaking is impossible except if I somehow add more ADA to the wallet… or is there another technical reason for not being able to unstake?

@xellieza You need to have some available ADA in your wallet to unstake.

@Tobi : Thank you for the response… is there any indication how much? I ask because with other tokens like Solana or Eth, a clear indication is given if gas fees are required… in this case howevee, an error screen pops up…

@xellieza The fee varies and is also not charged by the app.
You could deposit not more than 10 USD of that token.

1 Like

Thanks @Tobi, will add a fitting amount and retry unstaking my ADA. Still puzzling though that with other Tokens (ETH) you get a clear communication what the gas fees will be, and that there is not sufficient Tokens / Money available to initiatie the action… but not with ADA…?

Hello, I’m staking ADA in my wallet, but for more than a week I haven’t received any reward. On the top of the screen there is a message “ Trust Wallet’s Cardano endpoint is facing technical issues, disruptions in transfers, staking and balances are expected.
We are working on a solution.”
Do you know when it will be fixed and will I get my staking rewards which were not credited during this time? Thank you

@vferley There’s no ETA, please contact the support team if you have further enquiries.