Aion deposit problem

Continuing the discussion from Sent AION coins to my wallet, received but the balance is not updated:

Dear friend
I faced thiss issue yesterday and I tried to do below actions:
1-remove and reimport wallet
2-using VPN and test several VPN connections
3-removing trust wallet , reinstall and reimport wallet
But problem is still exist, I’ve had same problem with QTUM before but changing VPN worked miracle at that time,

Transaction hash#1:

Transaction Hash#2:

Please help me to solve this issue,


I have the same problem.
I have 2800 AION in my wallet, but now it show 0.
Can somebody help?

1 Like

I have same problem where support team to fix it problem
Any one help us

Same problem too here.

Transaction exists everywhere, even Trust tells me it’s been received but 0 AION.

AION shows 0. What’s going on? Please Resolve. Too many issues with Trust wallet.

Thanks for the report, @Meysam_s_h_22! Reported this issue to the dev team.

cc: @NosiMor @Fondul @jackulz1 @Swifty

Update: This issue was recently fixed by the Aion team. Please refresh and check your wallet again.

Still nothing unfortunately. Not sure what to do next? Have already tried to uninstall.

@jackulz1 please send the following:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. AION wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)
  3. Transaction hash or link
  4. Screenshots of the wallet (including errors or missing balance)

App 5.24

Transaction: Aion | Explorer

@jackulz1, try to use a VPN then refresh the balance. Let me know what happens.

No luck using a VPN unfortunately… any other ideas? Been a bit of a headache trying to figure this out.

Gotcha. Reported it to the dev team and they will take a look at it. Will inform you if there are any updates to be done.

I made a video to solve that problem.


“Aion tokens doesn’t show in Trust Wallet balance - Solving The Problem and Your Coins”

I hope this helps :wink:

Isn’t there any useful update?
I tried more and more using vpn and reimporting wallet but problem is exist, it maid me tired ,
Thank you for your help

Raised this issue to the dev team. Will do a follow-up. I’ll let you guys know if there’s anything to do.

Please let us know because we do not know what we can do and there is a lot of people that have same problem.

Hi everyone!

The dev team has found the issue and a new version will be released. Keep an eye out for updates on Trust Wallet’s app store page:

Thank you for supporting and following this issue.
I’m waiting for it.
Best regards

1 Like

To anyone who experienced this issue, please update to version 5.25. Let me know how it goes.

1 Like

Problem has been solved after updating , thank you for your big help.

1 Like