App not responding

Trust wallet app has not been responding
Not refreshing I don’t know if am the only one with the issue or is anyone experiencing it as well please admin look into the matter thanks in advance :blush:


Am not experiencing anything of such

Mine is working perfectly well!
Maybe, you need to update your wallet to the latest version and then try again.

I’m sure it’ll respond when you do that.

1 Like

The app is working perfectly okay. Try to update your app to the latest version.

It’s working now thanks guys

1 Like

Yes for me app not responding and I finished my update also but not possible

Hello @Ratheishkumar,

To better assist, please provide us the following information:

  1. Trust Wallet app version (go to settings and press “About”)
  2. Your Android/iOS version
  3. Further details about your issue (please explain what you were trying to do before the app crashes)
  4. Screenshots of the wallet (errors, if any)

Please admin check this my funds are now 0.00i can’t even find my twt coin anymore please help @admins

Hi @Linaanol,

Please reimport your wallet by following this guide :arrow_down:

Good morning @iamdeadlyz I just did all this as you stated it on my iOS device

am still having this and the pages are not loading I hope I haven’t lost my funds because my phrases are intact with me

Please enable the TWT token and double-check the address. Refresh as well, so the balance will be displayed.

Hello, can anyone help me. My Value liquid tokens are not showing a price on my trust wallet however I can trade them etc on uniswap. Any idea why this is?

Hi @Spiralkut,

Please check this guide on how we get our pricing data :arrow_down:

@iamdeadlyz it’s still not showing I have tried searching the coin but I can’t find it is there any other means to do this

@iamdeadlyz please this I what I keep experiencing I have also tried to use my android but to no avail and the price of other coins ain’t showing my eth is enabled and my zcash as well but my funds there are not showing I can’t even find twt where I can enable it

Twt is not even showing where I can enable it

this is what I keep getting is been loading for the past 12hours I have also tried using my android it’s still the same

@iamdeadlyz I have tried this and it’s not working I can’t even find the coin on search is there another means I ca get my funds back and also the prices are not showing as well

I will relay this to the dev team. Keep an eye out for updates and thanks for your patience!

@iamdeadlyz thanks so much and my app is upto date hoping to hear from you soon :disappointed_relieved::disappointed_relieved::disappointed_relieved: I feel so terrible loosing my hard earned funds