App on Honor: can't print the dot

Hi all.
When I try to sell crypto, I cannot set the correct amount - the dot is not set. I can put a comma, but it is interpreted incorrectly and a message appears that I must enter more than the specified amount, although I enter an amount greater. This problem is only on the honor phone (I tried two different Honor phones), on a Samsung phone with the same Microsoft Swift keyboard everything is ok.
I also tried Google keyboard on Honor, the problem persists.

@devidart I’d advise you open a support ticket from your Trust wallet app.

To reduce response times from customer support, please include the following info in the ticket:

App version, device model, wallet address, TX hash (if available), and the blockchain + assets you’re experiencing the issue with, and any relevant screenshots or videos to duplicate the error.

@Tobi , thanks, I already tried to do this from a desktop, but they asked for a login and password, which did not fit and it was impossible to register. I sent from the app

@devidart You can submit a ticket also at
Tap the upper right corner to submit one.