Approved BUSD for swap

I just wanted to say that I have had a similar problem as this. It has been happening to me over the last few days. They were all (4 times in total) set to a value of zero but recorded on the blockchain, so I was charged for gas for the privilege. The first time was after I tried to cancel a swap as well, but mine was straight from the trust wallet swap feature. The 2nd time was in the trust wallet swap feature as well, but I didn’t cancel it. Both of these transactions took until the next day to happen, and there was nothing on BSCScan for them during that time, in fact they were pending in the activity list for hours then disappeared for a long while then suddenly, all at once they were finalized even though they appeared to longer be in the app. I figured they took too long and we’re just cancelled. There were 2 more transactions that this happened to, but they were through exchanges. The only common thread I could come up with was the wallet, just like the letter stated. All of my jenky transactions were on the BSC network.


Hello @owltheal
Can you please provide your receiving address and the transaction hash relating to this swap you said.
Also please provide what app version you are on.


The hashes for the 2 transactions I mentioned:



My trust wallet version is from the Play Store: version 8.1.4

It looks like it just happened again when trying to swap Mbox for USDT. The hash for that one:


I was trying to swap BUSD on the BSC network, for Bnb smart chain, the sending/receiving address:

Transactions’ hashes:



Google Play Trust Wallet App for Android version 8.1.4

1 Like

@owltheal Those two transaction hash point to you making an approval before a swap.
When swapping for the first time, you need to approve your tokens first before you are able to swap.

Hi Tobi,

My topic is unlisted and apparently I can’t reply to the topic. May I ask you why? I’ve already created a ticket in your system but I’ve gotten no reply yet.

I hope everything is okay. :slight_smile:

@jessicas Please wait for a response from the support team.
You’ll be contacted.

1 Like

It’s been over a day and I still haven’t received a message.

I want to buy that coin before its price increases. Since this is due to a bug in the application, I hope the team will issue a refund. Because this would be fair. :slight_smile:

@jessicas For sure, you’ll be contacted.
Please be patient.

1 Like

Hi Tobi,

I understand I should be patient but it’s been two days that I haven’t received a reply yet. It’s very frustrating because I want to buy it before the price rises.

They’ve already told me that the team were already aware of the bug. I think it shouldn’t be hard to refund 1.25 eth. :slight_smile:

@jessicas What is the ticket number please?

1 Like


I guess that’s the ticket number. Sorry if it’s not because it looks like I got a blank e-mail.


I still haven’t gotten any reply from Trust Wallet. It’s been over three days. It was really not my fault. This is not fair. :frowning:

I can’t embed media items in a post. If you can send me a private message, I want to show you. Thank you, Tobi.

@jessicas Please open another ticket and leave a detailed complaint there

1 Like

@jessicas I have escalated internally, you’d get a response soon no worries.

1 Like

Thank you very much for your help, Toby. :slight_smile:

I hope I get a reply today. :slight_smile:


Hi Tobi,

It’s really frustrating that I have still not gotten any refund! It’s been over 10 days. Come on guys!

@jessicas Sorry for that, did you create a new ticket ? Because that will further push your request but if not, please send your ticket number.

I realized you were correct about the hashes I provided, but I felt certain that I did a BUSD to bnb swap and never received it. I went back and checked several times until I figured out it was this hash and that both coin histories in the app have a record of it. It is listed a swap on the blockchain, but has a value of $0.00, even though it starts the transaction by taking the BUSD from my wallet. It never came back to my wallet though. Here is the correct hash:


I received 2 emails from support a couple of days ago right after submitting a ticket for this. Since they were close to when I sent the ticket I assumed they were letting me know that the ticket was received, but I haven’t heard anything in a couple of days now my ticket number is:


Can you help me with this?

@owltheal You’d need to wait till your ticket is responded to.
Besides, checking your transaction hash again shows you received the BNB, here’s the transaction

Sometimes transactions may not be shown in your Trust app history but you can always confirm on the blockchain as the blockchain is always accurate.