Approved token took gas fee

I’ve had the same issue today. Tried 2 swaps to eth and it charged me a fee but didn’t swap. Tried swapping from erc20 token to another in uniswap and it charged me a fee but no swap. And then I tried another swap that didn’t work and got charged a fee. I did notice after that that when I go to final page to confirm transaction it says 0 eth at the top. Idk what’s going on, but it’s almost like the eth address isn’t right in trust wallet because it’s taking out but won’t put eth into it. This is the same wallet I have been using to receive my eth from Coinbase, so I know it can receive it.

Hello @Shafercb78 can you send your wallet address and transaction hash.

Wallet address

0x17e0359D8BED7315beFad09c785fFd528825f917

Tx #

0x4483be070c7995f39360abb19022bb663adb10f6c0ac320650ed5b08d55626b3

0x825acac38f15c6704194e94626d89ff1449049ee9fd88a4c30f53d5f4fc092ea

0x7d69cd3a3b9115d109ff55aadffa4784192041f46c84c8412986a40b8351e55b

0x5091ca9d47f9a5ab0a6dd7ff7fad0d74cbb8b1c2e20015fae5cd4b29f17f7ac3

0x57e80237831b079c884c2252e06bb8362ff598364c2ce8cccf93eee9f4552f1e

@Shafercb78 When swapping tokens for the first time, you have to approve it first to be spendable. And, that is what you did just now.

Since you are done approving the token, you need to enter the amount that you want to exchange then press the swap button.

All in all, you will confirm two transactions: approve and swap

NB: Both token approval and swapping transactions needs gas fees.

It went through this morning. The confirmation page looked totally different then what it was saying, even earlier this morning when I was trying to swap.

2 Likes