APT balance not showing in Trustwallet

Hi I tried to send my Aptos to trustwallet, transaction details have appeared on the APT token page of the app but the balance remains 0. I have also confirmed the transactions and balance is visible on the Aptos explorer for my correct address.
I followed this guide (Steps in Finding Missing Funds : Trust Wallet) to find missing funds by re installing my wallet on my device but this did not work.
Any thoughts of next step would be very much appreciated.
Further details:
App version: 8.8

Aptos Address:

Transaction hash:


Thanks in advance

1 Like

Hello @Jleg13 you are right it’s in your wallet

Can you reimport your wallet and see how it goes or delete the app and install it back again ? but make sure you backup everything before , take a look here

1 Like

Hello, yesterday I found exactly the same problem with my aptos. reinstalling the wallet did not help. after it, my entire aptos balance became 0.


Hi there, thanks for your quick reply😊
I tried to do the reimport again plus tried deleting the app plus tried to import on a different device, tried different internet connection like is mentioned in the attached guide. The balance is still not appearing in Trustwallet though……:thinking:


I have the same problem. Yesterday I send apt to my wallet.
It didn’t show on my balance and after I reimport my wallet, the current balance turns to 0.

I can see them on blockchain, I also connected liquidswap and connected my wallet. and I see my balance there.

Tried to swap but when it asks for permission, trustwallet show loading screen then “request timed out”


Hello, Trustwallet still not showing $apt but I found a way to retrieve the assets

You can import your wallet to martianwallet, which is a sui and Aptos wallet with your secret phrase.
I am able to send and receive assets, so funds are SAFU