ATOM: Unable to unstake

I am unable to unstake ATOM.

Since I can’t unstake it, I can’t transfer it out. It tells me I do not have enough ATOM. That is incorrect.

Trust wallet version 2.12

Please help?

Hello @suspiriumpuellarum To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

  1. Screenshots attached.

  2. cosmos1p22l40d838jylhh2l0hylu65pqtyqv5yyr8fyw

  3. I want to send my ATOM to another wallet. Since I cannot install, I cannot send it to another wallet.

Thanks.




1 Like

@suspiriumpuellarum A small amount of Available ATOM (non-staked) needs to be on the wallet in order to pay for the transaction fees. Minimum transaction fee is at 0.001 ATOM.

Read more here: How to Unstake Cosmos (ATOM) Tokens

Yes I understand that. I am not able to unstake ATOM. Even if I leave some ATOM to cover fees. It is an error with the Trust Wallet application. Can you help?

@suspiriumpuellarum
The ATOM required for unstaking must not be a part of your staked funds.

Hi,

I have a slightly different issue.

  1. Trust wallet app version: 2.12
  2. cosmos18xyqfr0y8fe2qppcsdxdrpkedj5tn7sjewpdhu
  3. n/a
  4. I tried to claim rewards and I got the error message

code: 12, message: ‘Not Implemented’, details: [] },
status: 501,

  1. The same error occurs if I try to redelegate or unstake.
  2. I clearly have enough ATOM in my unstaked balance to do everything, but I have the same error message.
  3. I’m not allowed to embed screenshots, sorry. Maybe because I’m new?

Hello @Peter15 you are using very old app version of Trust wallet. Update your app to latest version and unstake.

Ah, I thought the app was auto-updating.
I just realized: I moved to a country where the app does not appear on Google playstore.

Will find a workaround.

Thanks