Bitcoin set from NiceHash not appearing in Trust wallet

Hi there, I’ve sent one bitcoin transaction from NiceHash previously and it worked no problem. Today I sent another and it has not appeared.
I sent it to my wallet address:bc1qszda8g2z2e387wzl46wfmt4547ervckpxmnvl6
The bitcoin address appears to be: [9c6bff80c1d0a5d191a3878c07a4333a409d42938cafd3c1c7a9d5ce1c0ea493]
and is successfully confirmed according to blockcypher:
https://live.blockcypher.com/btc/address/bc1qszda8g2z2e387wzl46wfmt4547ervckpxmnvl6/
Is there anything I’m missing here, or is just taking a while to get to the wallet? Just want to make sure I’ve not lost my bitcoin, and if I’ve made a mistake, not repeat it.

Thanks!

Hi @ritchieyoung,

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. zPub of Bitcoin:
    • Open the app
    • Go to the settings
    • Select “Wallets”
    • Press the 3 dots or “i” icon near the wallet that you are using
    • Export the public key (NOT THE PRIVATE KEY NOR THE RECOVERY PHRASE)
    • Copy the zpub of Bitcoin
    • Then send it here
  3. Screenshots of the wallet (including errors or missing balance)

Hi there, thanks for the response. After following all the tips on here and updating the app (since unbeknownst to me it doesn’t update itself!), and still not seeing my balance, I posted the information above.
Thankfully however, it has appeared in my wallet by this morning. It may have been a combination of just waiting long enough, and updating to the latest version of Trust. Everything else had checked out ok.
So, I’m good, have a great day!

1 Like