Cannot connect to Ellipsis finance using TW

Hi,
I’m trying to connect to https://ellipsis.finance/ but can’t.

I can connect to PCS etc with no problems.

Can anyone let me know if TW connects to Ellipsis?

Thanks

1 Like

Hello @Bozo,

It works fine on my end.

Clarification:

  • What is your Trust Wallet version now? (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  • Are you currently using mobile data or WiFi?

Hi, thanks for the reply. I’m using Mobile Data and version 1.27.18.

I just tried it again and it still won’t connect.

When I click the connect wallet button an orange border shows around it but it doesn’t connect.

Odd. It won’t connect on my end as well (it worked last time based on my previous response). Will ping the Trust Wallet devs about this.

1 Like

Have you heard anything back from the team . If you haven’t can you let me know whenever they get in touch

Thanks for helping out.

The issue is with the DApp itself, not the Trust Wallet app.

You can contact the admins or dev team to notify them about this issue. You can share this guide as well: Optimize Your Ethereum DApp for the Trust Wallet Browser

1 Like

Hello I faced the same issue as well. Can I know how do I get help with this pls? Thx you! :slight_smile:

Same here. I can connect with Ellipsis, But when I try to claim my rewarded EPS tokens from the Ellipsis Lock, nothing happens on my wallet and I can’t confirm the transaction.

Hope this gets solved soon.
D

Hi Bozo,

Have you already found out what the problem is. And are you able to claim your EPS from Ellipsis via TrustWallet?

2 Likes