Cannot send my filecoin

I try to send my Filecoin to another address, an error message of “method not supported” was shown so i cannot perform the transfer. I sent coins to the same address previously, and it was fine.

I have definitely left a sufficient balance for gas fees.

I have raised tickets to support, but apparently, no reply to address the issue.

Trust wallet, please resolve the issues asap!


Hello @Jeffjgl,

Thanks for reaching out.
Currently Filecoin $FIL transactions are not working on iOS. We are currently working on a fix which will be available in the next update soon.

Android users remain unaffected.

We will keep you updated


Please also share the detailed guide to make a transfer via other means asap. I would need to perform transfer asap


When will be the next update of trust wallet be? is any way that i can make transfer via other means in trust wallet other than ios and Android?


i have a problem with FIL coin too. it’s been completed on network but it’s not recieved in my trust wallet. i use android device.


Hello @bitcharger @Jeffjgl,

The Fil issue is now fixed. You can try to transfer again.
If problem persists let us know please.


I have this error now and i cant transfer my filecoins,i have ios and i have latest version of trustwallet.

1 Like

Hi Alan,
Thanks for the follow up. I’ve sent them from a CEX to my trust wallet. after few hours i posted the issue i got notification on trust wallet app about FIL amount received. transaction completed and in the walle transaction is visible but balance not showing the received amount. should i re install the app?

1 Like

Unable to send any amount of my filecoin balance. It is giving me this error

‘Filecoin.GasEstimateGasLimit’ not found (-32601)

1 Like


Same issue here.

I’ve sent some FIL tokens to TrustWallet, the transaction appears on the application, but the total amount says 0 FIL.

Another thing is that if I visit the explorer and search for the public address, the amount is also 0 FIL. That concerns me a little.

I am using iOS, don’t know if has anything to do with it.


Having issues no matter how much I send @Alan47 i have noted the error message in my reply post above. Assist appreciated.

i already re installed the app but no change. transaction shows it received but balance shows zero

BCH same issues with error “RPC error estimate fee” on Android phone. Newest update

You should contact the CEX that you’ve used to make the transaction and ask to reject it.

I try to make some transaction but: “Missing tx blob - Code: 400”
BCH Issues, newest update Android too…

1 Like

how do i make a post separately from this one? There is no button for making a post. It seems I only have buttons for replying to already existing posts

Hi Alan,

Any news on fixing this issue? It appears to be impacting iPhones too. Is it a network issue?

I am showing the same issue on my iPhone. Shows a complete with no balance showing on Wallet. I completed this transation on March 27, 2023.

Binance support resolved the issue by rejecting the transaction. ETH causes it by running out of gas.

Hello, @Alan47
I have a problem of withdrawing my Filecoin(FIL) from my trust wallet.

My trust wallet says the error message ‘minimum expected nonce is 4: message nonce too low’ whenever I try to withdraw my Filecoin.

The version is my trustwallet is now 8.7 updated and my Filecoin(FIL) address is ‘f1k5nmzhgl72znquz5ipfnfunu5c7dzjoia5skacq’.

Also, I’ve already tried both of Automatic mode and Manual mode of Node seetings of Filecoin network but the problem hasn’t been solved at all.

Should I wait for the further updated version that solve my problem now or do I have to try another thing to fix the problem myself?

Let me know what to do, sir :slight_smile: