Cannot unstake BNB on Binance Beacon Chain

Hello - I am receiving the error "Cannot read properties of undefined (reading ‘validatorAddress’) when trying to unstake BNB from the Binance Beacon Chain using Trust Wallet and Ledger wallet.

Please advise, thanks


@OAU Please open a support ticket from your Trust wallet app.
Before opening a ticket, ensure you have tried troubleshooting the issue yourself first, you can use the chatbot in your settings for common troubleshooting
Settings → Support
Then if you still have the error, open a ticket

To reduce response times from customer support, please include the following info in the ticket:

App version, device model, wallet address, TX hash (if available), and the blockchain + assets you’re experiencing the issue with, and any relevant screenshots or videos to duplicate the error.

Hi @Tobi - I tried the chatbot before, but tried it again after your reply just in case, but it did not help resolve the issue unfortunately.

@OAU You can submit a ticket there also if the chatbot didn’t answer your questions, just tap the upper right corner and Submit ticket there.
Please ensure you provide a detailed description of the issue also.

I am using Binance Chain application version 1.17 (on Ledger Nano S).

Below are the steps I am following:

  1. Connect wallet
  2. Click on BNB, then native staking, unstake, max, unstake now.
  3. Note I checked the estimated gas fee and I have sufficient BNB in the wallet
  4. Click confirm
  5. Then I receive the error msg: "Cannot read properties of undefined (reading ‘validatorAddress’). I tried to attach jpg of the error but it says I cannot post media
1 Like

@OAU There is still no support here so you’d need to submit a ticket and state all these there.
Open through your Trust app or here:

You can click the top right corner there to submit a ticket.

1 Like

Hello, I have the same issue, how did you managed to resolve it ?

I am stuck

@ItsMoonrack Please read my above message, you need to submit a support ticket as there is no support here.

Did you get this issue resolved? I’m getting this too on a ledger nano s.

@Malcr001 Please if you require support, the right channel is to submit a ticket to the customer support.

1 Like

I’ve already raised a support ticket but I’d like to know if OP is still waiting for a response here as this has clearly been an issue for over a month now.

I feel like I’m painted into a corner because I don’t have any alternatives to unstake other than through trust wallet extension. I really don’t know why bnbchain . org doesn’t let us use the older BNB Chain Wallet to unstake as this is what I used to stake.

1 Like