Can't move TRON off of Trust Wallet

I moved my TRON off of Binance and now I can’t do anything with it. I want to get it out of the Trust Wallet, but every time, regardless of the amount, it keeps saying insufficient funds. It also won’t populate the max number of TRON for sending. I have to manually enter it but nothing I do is working. There is no way to even change it to another crypto. I feel like I just got scammed big time. If not, please help.

Version 1.26.5

Crypto Address: TEE3vA4qk1aa4wrXvojLE6jahDWL4K4uT3

unstack them first it says you freezed your tron.

1 Like

I thought it was too but I’ve tried repeatedly. Here’s some screenshots. First one shows when I go to “unstake” and second one shows that nothing is staked.

Weirdly, if I go to “Stake” and press the MAX amount of TRX, the box populates with the full amount and allows me to continue. I haven’t pressed Continue, however, as I don’t want to stake the TRX.


go to then download tronlink wallet import your trustwallet 12words after syncing. up left side of the app there is a Freeze/unfreeze button you can unfreeze you trx from there

1 Like

Thank you for advice. I tried to do this yesterday and maybe I’m doing it incorrectly. I apologize for my ignorance on this process but need a little more help. On Tronlink, I chose to import the wallet and in both the Private Key and Keystore, I entered my 12 words and they both said incorrect key.

If that is not the correct place to enter my 12 words, would I do so on Mnemonic, and if so, do I choose HD wallet or Non-HD wallet? I read NOT to open under Watch Wallet. Any advice is greatly appreciated. Thank you for your time.

I am having the same issue too… Did you fix this?

My TRX will not allow me to move TRX off Trust.