Deposit ADA but amount is still Zero

Helo… I’m having problem in deposit ADA (cardano BEP2)… The information shows that the deposit received but the amount is still zero. I try also to swap to smart chain but it also zero. So I cannot do any transaction and my ADA stuck somewhere. What should I do to fix this?

My address is bnb1yaevpukrqa5z3y22xre6pn9qr9l9hgp9t5sxts

Version 1.28.0

Please need help

Hi @jeffreychristantotw,

A bit confused with your status bar…are you using mobile data or WiFi?


Anyways, please read and follow these:

  • Make sure you are using the latest version of the app.
  • Use WiFi with a strong internet connection instead of mobile data for the app to display the correct balance. If it won’t work, use WiFi + VPN as well.

Maybe you fill the memo, then your deposit sucess but your balance is still zero

I use WIFI and there’s no problem with internet connection. This is already the latest version. I just tried to use VPN and still doesn’t fix the problem.

Please need your help…

I don’t fill anything on the memo. the balance is received, but its not update on the wallet amount. How this could happen, I think there’s a problem with trust wallet system.

Memo is not needed when receiving cryptos to your personal address from the Trust Wallet app. Perhjaps, @TIMOTIUS2021 mixed things up.

Anyways, try a full reinstall of the app.
Make sure you have a backup before you proceed.

Uninstall and then reinstall your app.
Follow this guide to restore your wallet.

I have the same issue here.

I’ve emailed support with no response & tried all the steps here
but still the coin was not shown.

I have tried a full reinstall and restore the wallet as well…

Is it only happening on ADA?
I was about to send BNB and USDT to this wallet but I’m afraid the same thing will happen again.

Hi ivanaries,

Based on mu case… you can try to use VPN and restart the app, this should fix the issue.

Finally, I got the issue fix.
It was because in Indonesia, we need to use VPN to access some non-regulated financial services.
And TRUST wallet is one of it.

  1. activate VPN on the mobile phone
  2. Go to TRUST wallet
  3. Refresh your wallet

Hope this help people who are helpless and hopelessly waiting for TRUST customer service to reply their email.

This happened to me, but in busd transfer to bep 20. I’ve tried vpn and refresh wallet. I stll haven’t received it in my trust wallet. The transaction is 0x5f774bdca0a0315014410e5c85edb153b9d4ffbf1ee3d91018ca528593567867
It’s been 6 hours. What do I do?