Dogecoin Balance is 0

I recently brought a bunch of Dogecoin and tried to transfer it to a wallet that I can sell on, the transaction froze and didn’t appear on the blockchair at all, so I reimported my wallet but the balance shows at 0. I searched my address using this website (Dogecoin Balance) and the batch of Doge I tried to send over is still attached to the address, just not showing up in the Trust Wallet. I have tried reimporting a second time but it still comes up as nil and unfortunately I do not have a second device I can try and import the wallet too. Is there anything else I can do to have the coin show up?

P.S. I have tried to follow the “My Crypto is Missing, What Should I Do?” guide, but it has ultimately brought me here.


Hi @AmishKahn,

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. dgub of Dogecoin:
    • Open the app
    • Go to the settings
    • Select “Wallets”
    • Press the 3 dots or “i” icon near the wallet that you are using
    • Copy the dgub of Dogecoin
    • Then send it here

I’m using app version 5.16 (5166) and the dgub is dgub8sRrHUeCt7sPXNAZVSJTKH6esh43kH5p9K8ZzPdAvqSq6NRZiyGnVvv8wxcKDEHD38eYKYqev3ptPfN7bMXH7D6vKFPFhzVRBDHidQWyv75

Thank you for providing the requested information.

You indeed have 2833 DOGE on your wallet: DRtCdbCW4mAgozsj7DP6AaKCXhU514JcYK.

To fix the issue, please try to use a VPN then refresh the balance again. Let me know if it works or not.

Unfortunately it hasn’t worked, I’ve tried connecting to several servers and reimporting each time, but the Doge is still showing as 0 in the wallet

I see. Now, backup your recovery phrase (guide: How to Backup a Multi-Coin Wallet) then uninstall the app. Install it again and import your wallet by using the recovery phrase.

That one worked, thank you very much

1 Like

You’re welcome! If you have further inquiries, feel free to create a new thread/topic. Stay SAFU!