DOT unstake issue

Hello, I have not been able to unstake DOT, apparently there is an issue that is coming up for a while when i try to unstake it. does anyone know when this is going to be fixed ?


Hello @iDhavalDP What’s your Trust Wallet version ?..


I am in thé same situation. When i Want to unstake or stake again DOT a message says : transaction error 1010 invalid transaction transaction IS outdated code500 . What Can i do please ? Thanks a lot

Hello @Jackryan51
Can you confirm if you have the recent app version; if not, do update the app and try again.

Hi Tobi !! M’y Bad i forgot to update thé app . All IS ok no thanks a lot

1 Like

The same problem but different error: no sufficient balance. Also if I put one… I stake all dot in the last December the I think 28 days are past…


Same here, staked 254 DOT for several months and tried to unstake. Same issue “no sufficient balance”
I have the latest app version and over 10 DOT available.

Anyone know how this can be solved?

@Ronny2x4 Please wait for a patch, DOT is currently having issues.

The same problem for me, insufficient balance, but I’ve dot also for the commission :sob:

1 Like

When I try to unstake my DOT I choose MAX and the message “Not enough balance” is displayed in red. Please help!

1 Like

I have the same problem, cant unstake my DOT - “Not enough balance” but i have some transferable DOT for comission.