Finding the ETH that I received

Hi,
i got the similar issue, with eth transfer. Shows received but balance not upating and cant swap.
Tried: the wallet delete and recovery, reinstall app, vpn, 4g vs wifi.
Havent tried different phone.

App version: 1.28.0
Eth wallet: 0x57fC4a5E2C3cb80E3a36B8718e0327B2737bAEad

Transaction hash:
0x1326d94603c0f62ebb4e006585aeeaf489571e509ed5369d6de4ea44eb7afdc6

Coulnt upload images but the balance shows: 0.0131884 eth and shows the 2.8… Eth received in the transaction list

Hello @M3rcury,

PLease try to upload the screenshots again. You should be able to upload now.


@M3rcury hey,
Sorry for the inconvenience. This problem has been solved for now by our developer team. Refreshing the app should show you correct balance.

Hi,
Just now did the remove wallet and add it back again. Also force stopped the app and cleared cache after that.
It still shows the same numbers as on the screenshot.

I see, Will let the team know about this. Please be waited meantime. I’ll follow-up with you with any updates

Hi,
The problem is now solved.
I thought I might try the wifi vs 4g recommended fix.
Going on to 4G and refreshing did the trick. Hopefully this problem won’t happen again anytime soon.

Thanks for the quick response.

1 Like

i am also having the similar problem. i sent some eth from metamask. but those eth is not showing. please help me

@farzana93 provide details asked on this thread: missing currency from metamask

1 Like