Hi there

I staked my DOT-s about year ago in TW and left it there.
About a month ago I was trying to unstake and wasn’t able to. Doing reseach since what to do but no luck.

Only message I get is: “The minimum amount is 250”.
So as I understand they raised the bar for minimum staking but I want to unstake.


Staking in P2P.ORG

Newest iOS, newest TW, also tried in Chrome extension

Waiting feedback from TW and P2P.ORG as well.

Any help much appreciated!

1 Like

Hello @andruss
Please wait for a patch, DOT is currently having issues.

1 Like

Case closed! :slight_smile: It was all my bad and bit embarissing mistake. I staked all my DOT-s, didnt left nothing to pay for UNSTAKE fee. Thanks to Trustwallet as well, they were helpful!

I staked 583 DOT. It says I have 3,73092 DOT available. When I try to unstake, it let me enter maximum 2.6 DOT. If I enter 2.7 DOT is says “Remaining is less than 1.1 DOT, please send max amount”. If I choose MAX (583 DOT) it says “Not enough balance”. Please help!

I have version 8.1.4 Android. I don’t see any update. Do you know when an update will be available?

@adrianciocalau Please wait for a patch, DOT is currently having issues.


Thank you for the reply. Any idea when a new update is scheduled? It’s kind of frustrating to not be able to access your funds especially when you unstake and you have 28 days of waiting anyway…

@adrianciocalau Please be patient, it should be fixed on the next update.

Hello! I found a way to unstake your DOT - I installed the Trust Wallet Chrome extension and it worked fine from there. I think the bug is only in the Android App.

1 Like

Were you able to redelegate on the chrome app? And does it show the transaction being unstaked on the mobile app?