I’m unable to send btc out

Every time I tried to send out bitcoin to external wallet it kept on to display (Please consider decreasing sending amount or topping up the balance),only with bitcoin not other assets, I have enough balance to pay charges


I’m in the same boat, need help understanding what is going on.

I add more money still can’t send, I decrease sending amount, still can’t send.


Update on this for anyone else having this problem; as of when I post this the transaction fee for BTC on trustwallet is 0.00113862 for 0.00140299 BTC, which is £70 of a £90 transfer. its a lot lower than it was but still higher than ive ever seen it before and not ideal when you have to make small transfers. have made a post that is pending asking how to monitor transaction fees which might get some advice on how to do so. admin is right about needing to wait but would like to be able to monitor how transaction fees are looking before spending too much money trying to get a transfer to go through, especially when the app advises the user to increase the amount you have only for it to still not be enough