I tried creating a topic

Hi - I created a new topic a couple of days ago, and received a msg that it has gone for moderator approval. It wasn’t anything controversial but it still hasn’t been published.

Please advise.


@OAU Hey can you please state what the issue is here and I’ll respond accordingly.

1 Like

Thank you so very much for watching out fir me I really appreciate it!!! :blush::blush::blush:

Hi - the topic I created relates to unstaking BNB on the Beacon chain.

I tried unstaking using Trust Wallet (Chrome extension on Mac), with Ledger and receive the error: Cannot read properties of undefined (reading ‘validatorAddress’) - I can’t seem to embed a screenshot.

I tried reinstalling Trust Wallet extension, and the Binance Chain application on Ledger to no avail.

Let me know if you need any more info.


1 Like

Hello i have an issue my self so i swapped some eth for cosmos atom and i never got the funds? Please help!

@Zyrup_drosky please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, then attach it here)

  2. Crypto wallet address (press the receive icon near the send button, copy and paste it here in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)


How much time it took for you to receive the funds? Hope you did receive the funds :slight_smile:

Hey Tobi,

I have the same issue.
Tried everything but when I undelegate using my ledger it says:

The error: Cannot read properties of undefined (reading ‘validatorAddress’)

Everything is updated version
can you suggest anything to undelegate my bnb in beacon chain through ledger.


@lora2 I’d suggest you open a support ticket through your Trust wallet app or at support.trustwallet.com

I tried submitting a support ticket by clicking on the top right.
Filled the form and when i tried to proceed it ask me to log in to the support portal to access this page

How to i register for this portal?


@lora2 Please refresh the page and submit the ticket again.

I want to create my own question but there is not button for me to do so!

1 Like

Hi Tobi
I have the same problem with unstake from trust validator. Can I send you mine too? :heart:

Hello tobi hey so i sent some btc to another wallet but trust wallet is saying i used double the amount i got


Transactions hash is this

1 Like

@Zyrup_drosky Try reimporting your wallet and then check again.

Hi - look I feel a bit silly… This is not a reply but a question. I have just joined and have no idea how to post a question, only how to reply. Would you be able to tell me? Thanks!

@Adambest You just did right now. :smiley:

HI Toby - so, I managed to reply to a message - but how do I originate one? Thanks!

@Adambest You can create a new topic, if you’re unable to then you’d have to write under an already existing topic.