Issue with signing a message from imported wallet

Hi all, I have a little minor issue that maybe someone can look into. I tried to vote in the Aave governance snapshot ref a migration etc.

I have my tokens in a wallet(Eidoo) that I have imported to Trust wallet, my issue is that when I use walletconnect to connect my wallet to the vote system, to place the vote I have to sign the message with the wallet, but I get an ‘oops incorrect signature’ message. I had to connect my wallet through brave/metamask to get the signature to go through, and it worked.

So I guess my question is, did I do something wrong for it not to work in Trust, or is this possibly a bug that needs looking at.

Many thanks in advance!

9 Likes

Hi @along007,

To better assist, can you provide us the following information:

  1. Trust Wallet app version (go to settings and press “About”)
  2. Screenshots of the wallet (errors)
1 Like

Hi,

App version is: 3.8 (381) on iOS

I won’t be able to upload a screenshot as I have now got it to work with the brave web3 wallet

It was only a message signature issue from an imported wallet into Trust Wallet. I had to connect my wallet with walletconnect, then cast a vote in ref to token governance/swap etc, everything connected ok, but when casting the vote a ‘oops incorrect signature’ message would pop up

Noted. Will relay this to the team. Thank you for providing the requested details!

3 Likes

Follow up question @along007,

Can you send the link of the DApp that you were interacting with?

https://signal.aave.com/#/aave/proposal/QmbzqFQRMxicKMLLKwAf6bZ75hYNYEDkgnTiAsdsukcAFH

Gotcha, thank you once again! The team will investigate this.

2 Likes