Issue with USDT Approval + Swap

Hello everyone.

I have a problem when trying to (eventually) swap USDT to ETH.

As this if my first transaction, I read that I have to approve USDT transactions by paying the network fee, which I did. Status of the Smart Contract Call is “Completed”.

I read as well that I’ should be able to swap my USDT for ETH by using the Trust Wallet swap function.

However, when I hit the “Swap” button, I get the following error: “gas required exceeds allowance (115840).” I already have some ETH in my wallet in order to pay for the transaction, so maybe I’m seeing this because the fee required is higher than my balance?

I think this might be a system error, as sometimes I get a different message: “execution reverted: SafeERC20: low-level call failed”.

Thanks in advance to anyone who can help me out with this issue!

1 Like

Hello @martkur To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

1 Like

Hi Alan, thanks for your reply.

  1. App version is 6.6 (663);

  2. 0x4C2e433c92fFC4FE5a84b4F2d28E598d350180D0 - find attached the QR screenshot;

  1. (USDT Approval) Transaction hash: 0x0254cb3967955de00c55f27ed9716ea70e4ea18d06f5f5e16d8bbcc96b1efff5 - find it here:

https://etherscan.io/tx/0x0254cb3967955de00c55f27ed9716ea70e4ea18d06f5f5e16d8bbcc96b1efff5

  1. Screenshot of wallet and error:

Thanks again!

MK.

1 Like

@martkur it seems that the amount of ETH you have in your wallet currently is not enough for covering your transaction fee. Top up some ETH and try again.

1 Like

Hi Alan.

Yes, it seems that the fee was (unusually) high at that time. I got confused because everytime I tried to complete a swap, a different error popped up, so I thought it might have been a system error.

I tried again and was finally able to swap my USDT.

Thanks again for your assistance!

MK.

1 Like

Great! Glad to know that. If you have further inquiries, feel free to message us. Stay SAFU!

1 Like