Issues connecting to Ellipsis Finance with WalletConnect

Hi everyone, i have been using TW to stake EPS on Ellipsis Finance for a few months but i can’t connect anymore and so i can’t access my funds. When i try to connect with WalletConnect, it just prints a “connecting…” message for a few seconds, but then nothing. I have the latest version of TW (6.2 (6227) as well as iOS 14.7.1

hey please create your own topic if you want help ???

@Luccc83 here’s a new guide on how to use WalletConnect: How to Use WalletConnect With Trust Wallet

1 Like

yes i have tried it on other dexes and it works with uniswap or pancakeswap but not with ellipsis, but i have been using it for months and have funds on it. It just displays “une erreur inconnue s’est produite” when i try to connect to ellipsis with wallet connect. I have also tried to delete the app and reinstall it on an other iphone with the seed phrase but it is still the same problem.

That’s obvious problem is with Ellipsis not Trust Wallet as other DApps work fine. I think you should contact Ellipsis team to update their WalletConnect version as there was issue with WalletConnect previous days ago, you can forward this tweet to them:

the bottom picture is the message that is displayed, then it just disappears and it fails to connect