Java error when sending tokens

I am trying to send Matic tokens from wallet.matic.network, connected through WalletConnect to the TrustApp on my phone, but keep getting error messages:
java.lang.illegalStateException: Expected BEGIN_OBJECT but was STRING at path $[1]

I tried reinstalling it on another phone, but got the same error. Starting to panic because my tokens are now stuck on that Matic Wallet?
What to do?

Thanks for helping me out

1 Like

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About” and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste )

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors, if any)

1 Like

Hi Alan47,

thanks for helping me on this.

  1. Wallet Core 2.6.4 - version 1.29.3
  2. I was trying to send from the Matic online wallet (https://wallet.matic.network/
    address 0x9243e444f7db0de75f3b8722c433ee33e8a13adf
  3. don’t have this
  4. I connect the trust wallet on my phone through WalletConnect to the browser MATIC wallet on my laptop. Trustwallet asks for approval, works, they are connected and I see my MATIC tokens in my browser.
    I want to send MATIC tokens from the browser MATIC wallet to another MATIC wallet address. When I try to approve the send in the WalletConnect on my phone, I always get this java-error → https://photos.app.goo.gl/3bjjKVPZfdsEEidn9
    Tried to install Trust Wallet on another phone, tried accessing it on a different laptop, always this same message and inability to send the tokens anywhere.
  5. https://photos.app.goo.gl/knmdvoSmQR1up8va7
    https://photos.app.goo.gl/nAmBCHufPFc3rhRB6

Hello,
I’m getting the same error. Did you find the solution?

Many thsnks