KAVA staking doesn't give rewards

Heya guys, my KAVA staking suddenly doesn’t have the rewards column and it seems like my multiple stakings are not producing any rewards after the latest update by KAVA. Is there a reason why and what should I do?

Thanks :smiley:

1 Like

can you please share your kava address?

Hi @Shariful1000, my kava address is kava1y2fnvdq9aav6r2djg0yf6pu5e52n08rkzjvwtn

this address never had any transactions .
KAVAScan - Address kava1y2fnvdq9aav6r2djg0yf6pu5e52n08rkzjvwtn

I found out that I can view the details here, Mintscan - Chain explorer by COSMOSTATION

But my rewards are still not showing in the Trust Wallet

Anybody from @trustwalletapp can help on this? Thanks

Hi @taufinrusli,

What is your Trust Wallet app version? (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

It was 5.14 and I have tried to update it to 5.16, thanks

Since it is now updated, can you check the stats of your Kava again? The details for the reward should show up correctly now.

It’s still not showing in the iPhone App. I tried to import my wallet in Android App and it’s showing. Maybe you can try to test it on iPhone App

Thanks

Can you send a video recording of the issue? (you can upload it via Google drive then share the viewing link here)

1 Like

Always the same replies by these guys. Guess they are just here to gather infos and send it to the dev teams - always looks like they wanna blame you (like ICT support asking you if the power cable is connected).

There‘s obvoiusely a problem with collecting KAVA staking rewards in the TRUST wallet since the update to KAVA 5 failed and got backrolled. Like OP said, the staling rewards also don’t show like they used to and trying to claim rewards leads to an error message („nicht verfügbar“ = german for not available).

Let‘s hope the team can fix this asap or at least makes it possible to collect the rewards retrospectively once it‘s fixed since the date it stopped working.

Get your game on TRUST wallet! Your bugs aren‘t really instilling trust…

oh yeah:
KAVA adress:
kava1rle08y653c80s9rwmpuxq9nyq5lg9c47l2m4qs

app version:
5.16 (iOS)

No. That is not our intention.

Anyways, moving forward, are you experiencing the same thing as well?

as I‘ve just stated - yes

Please send us screenshots of the following:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. KAVA wallet address (select KAVA, press the receive icon near the send button, take a screenshot, and attach it here)
  3. Missing rewards in the page of KAVA.

this is what i mean. I stated above all the things you requested, but you wan‘t „proof“ that I‘m telling the truth. This makes me feel not taken seriously and also is a nice delay tactic.

but of course: here you go

accumulating staking rewards used to show on the far right.

believe me now?
fix it

We need it for documentation. No need to be hostile.

Moving forward, the devs are now notified of this issue.

You‘re right, I‘m sorry. Also nothing against you, I know you‘re trying to help.
I‘m just frustrated about the third problem with KAVA chain and trustwallet in 1 month, as I feel like reliability and security should be the top priorities for a crypto wallet and I felt let down by the product lately.

No worries, @mimu. It’s understandable.

Update. The devs have identified the issue, and they will release a new update. Since the last Kava network update, there were some changes, which cause an issue with calculating the rewards. The devs are aiming to roll out the fix early by next week.

cc: @taufinrusli