KIN withdrawel does not work

trust wallet,failed to send transaction: Transaction simulation failed: Error processing Instruction 0: custom program error: 0x1

Above message i receive whenever i try to sent a amount of KIN (sol) from trust wallet to I have enough SOL for the fee and are using correct kin version/wallets. It simply does not work.

Hello @Edwin05 To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

Let me step by step explain what i did.

  • transferred kin to trust wallet via []

  • made two succesfull test transactions from trust wallet to a ftx kin adres and [] kin adres.

  • two hours later tried to do a transaction to the [] kin adres again, after which i keep getting the error message.

I am able to send SOL but KIN does not work, I even created a new KIN trust wallet to test but get the same error, it seems to be something with the price calculation for the fee. i guess

Trust wallet kin adress
F3Z1vHsj2qnykC7TDD9UbTKohmmbdLYDL8ttNW3ZNNTu kin adress

@Edwin05 I don’t see any error screenshot on your replies. Can you send screenshot of the error please?

Sorry forgot those below you see the transaction im trying and the error i receive, i have 0.2 SOL so that should cover the fee

@Edwin05 can you try to re-import your wallet and try again?
Here’s a guide on how to re-import: How to Re-Import your Wallet


That did the trick, still got the error same message when sending the total max amount, but it worked now with lower amounts, have to leave 11 kin on the wallet.