Missing coins after reinstalling app

My funds are missing after reinstalling new version of Trust wallet. I tried recovery mode but still not showing. The address of my Trust wallet is different from the first one maybe that is the reason why my funds are not showing. I tried doing recovery mode and still nothing happens. Pls help me what to do to retrieve my funds.


Hi @Erwin80

In that case, you imported a different recovery phrase. It would be impossible for the app to generate new addresses if you did import the “correct” one.

Same issues I have being having since last two weeks and I saw an article about binance smart chain address change and did it but to my surprised my previous address was not showing there

Hello thank you for reaching out on me. I actually save the recovery phrase on my phone. I actually tried to input a wrong one but and will show an error message. When I tred to Input the correct one I made a successful recovery but the my tokens are gone already. I tried every single thing to recover my token searching in the net for solutions but nothing work. I did manage to track my old address in bscscan and still my tokens are there. Is there any way I can recover my tokens in my wallet. I will attaching screenshot of my wallet address the first and the second.

1 Like

Hi you are right I imported a wrong recovery phrase. I just find the right phrase and recovered my account successfully m. Thank you so much for your help and time. Regards

1 Like