Missing ZBC tokens on trustwallet

I transferred some ZBC tokens on the solana chain from Kucoin to trust wallet. The transaction was successful but I cannot see the tokens on my wallet balance. I have taken all the steps indicated in support section to access the tokens but none of them are working. Can someone help me here?


@Sirvoski Can you confirm if what you mean is you added the token already but it doesn’t display the coin value ?


What i mean is that I have added the custom token manually and yet the tokens are not visible.

See my wallet address below:


1 Like

@Sirvoski There is an issue with the solana nodes which is actually not a Trust wallet issue. You could either wait till it’s shown since you tried troubleshooting already, or import your wallet to another app and access the token from there.

1 Like

Thanks. But what do you mean by import my wallet to another app? How do i do that? How do i move the tokens to another wallet from trust wallet since I can’t even view it or have access to it on trustwallet?

@Sirvoski What I mean is if you need your tokens urgently, then find a wallet that supports solana tokens and import your seed phrase there to access your funds.

1 Like

Wow! Thanks! It worked. Never knew I could use the seedphrase from trustwallet to import my tokens on another wallet. I always thought I could only use it on trustwallet only.

1 Like

@Sirvoski Seed phrases can be used on any decentralised wallet hence one of the main reasons why you should always keep it safe as it is the access to your funds.