Moved to Trust Wallet from Atomic and dont see my holdings

Hi all,

So I got fedup with Atomic wallet and decided to switch over to Trust. I downloaded the app and used my seed phrase to restore my existing wallet. In Atomic i have BTC, HBAR, XML, ADA and some custom tokens. Upon restoring from seed phrase only XML migrated. I dont see anything else. I wanted to restore each of the crypto’s private keys but there isn’t a place in the App where you can go and restore from private keys. I’ve read thru a plethora of content on this forum, tried deleting and restoring the wallet over and over again. Tried a different device but get the same result, only Stellar coins show up and nothing else. Anyone knows what i should do. I also have Exodus wallet and on there i synced up the private keys from Atomic with Exodus and all is there. There is no such ability in Trust.

Hello @Triple_V,

The Trust Wallet app uses the Segwit protocol. If the BTC address from your previous wallet does not start with bc1, then it won’t appear in the Trust Wallet app.

Mainnet ADA and HBAR are not supported in the app. So it won’t appear as well.

He, i have the same thing.
Did you manage to solve it, or did you transfer it one by one?
Good luck,

No, I have no idea what to do. If I send it from one atomic wallet to trust then in charged network fees. But both wallets are connected to the same seed word, so my holdings in one wallet should show up in the other. In Atomic wallet I can get private keys for each coin I own but in Trust wallet I can’t find private keys for the coins, you can only restore from the seed word, I don’t see an option to restore from private keys. I’m don’t like this wallet much at all. I better use something else like Exodus or buy Trezor or Ledger.

I placed the private key from atomic in metamask, and from zil in a 3th pary wallet.
I did not have a lot of different funds on atomic, and the ltc and bitcoin did not have high fees to send.
Has to do with legacy and segwit adresses. Good luck, Wouter