My device doesn't support Trust wallet app

Helloz, I need help, I changed my phone and now the new phone says trust wallet version dont support it, My phone is android version 5.1.1 please assist me.

1 Like

@Ladybrih Hello what device are you using?


I’m using a Huawei Y560-L01, Android 5.1.1 i tried downloading an older version from the internet but those too give me parsing errors, won’t even install.

1 Like

@Ladybrih Can you try downloading from the official website

I have tried that and it leads me to Playstore and I get the app version not compatible message, that’s why I tried to go on google and search for previous versions and those give me parsing errors.

@Ladybrih trust wallet is compatible with android version 6.0 or above. Try to upgrade your device to be able to install. Read more: Where to Download Trust Wallet?