My polkadots have vanished


My polkadot balance in trustwallet is 0 but should be 22



already did that + uninstall/reinstall trustwallet

Can you send here the txid?

sorry… txid here:

issues on android should be resolved soon (~1 hour), on ios in 1-2 days in next release

1 Like

I am also getting the same issue with DOT. I have over 1k and the balance shows correct every few seconds then it goes back to 0.

1 Like

I am running android and installed the latest update along with re-importing my wallet.

1 Like

I have the same issue. The DOT balance shows 0 every couple of seconds. I use android. It does not allow me to withdraw due to “insufficient balance”.

It should be fixed right now

It comes and goes…

Still not fixed for me.

And now? Still not working?

Hi @blaine @KennyG1700 @wills

To better assist, please provide us the following information:

  1. Trust Wallet app version (go to settings and press “About”)
  2. Polkadot address

Trust wallet app version 1.19.15

It should be working fine now.

If not, try to do the following:

I just did all that and the problem still remains. I was able to withdraw most of DOT out of the wallet earlier today after multiple attempts with errors. I still have the small amount left and it is now allowing me to withdraw again due to “insufficient funds”. The balance still switches to 0 every few seconds.

Noted. Thanks for letting us know about it, the dev team will investigate the said issue.


Update: Please try to check again in 2 minutes, it should be fine now.


Please let us know if it worked, thanks!