My tron rewards is negetive

after I claimed my tron rewards it shows negative value
and it didn’t change my tron balance
I attached the screenshot of it
please help me

1 Like

Hello @saeed6296,

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. TRON wallet address (select TRX, press the receive icon near the send button, take a screenshot, and attach it here)
1 Like

You successfully claimed your TRX staking rewards. There are no negative balance. You can check here: TRONSCAN | TRON BlockChain Explorer | 波场区块链浏览器

Please re-import your wallet and let me know if the UI is still showing as negative.

1 Like

I reimported my wallet a few days ago
and I claimed my rewards again
but it is still negative
and my balance didn’t change at all

Please use WiFi with a strong internet connection instead of mobile data. If it still won’t work, try to use a VPN as well.

how does this relate to my internet connection?

The app should query your balance correctly. If there are internet connection issues, it won’t display the legitimate balance.

1 Like

I have a good internet connection, there is no problem for that , but every time I claimed my rewards. it didn’t change my balance

In that case, please backup your recovery phrase (here’s a guide: How to Backup a Multi-Coin Wallet) then uninstall the app. Install it again then import the wallet using the recovery phrase. Check if the issue is still existing.

A post was split to a new topic: I chose Memo Binance instead of Memo Ripple and it did not reach its destination

ok I’ll do it and after claiming my rewards I’ll notify you if it worked or not
thanks for answering

I stacked tron for 3 days and I got nothing for rewards :frowning:

23 March and 26 March, and everytime I hit the claim rewards, it says not available. wtf :face_with_symbols_over_mouth:

You don’t have any staked TRX.

The screenshot also displayed the unstaking tx.

before I unstacked it , i tried it many times , and it still said not available

plus if you notice it the unstacked message is silly , -12000 , I think it must be +12000 , why ?

Make sure you use the latest version of the app (1.27.17 or higher).

What language is configured on your Trust Wallet app right now?

the language is farsi , I still don’t understand why I get these bugs

Can you try to stake again and claim rewards? So we can check the issue in real time.

yes I’ll do it , I will send the screenshots , I hope they can fix it ,