My trust wallet has simply refused to give me price updates on any coin


This seems to have just taken place a few days ago. My trust wallet has simply
refused to give me price updates on any coin. After multiple attempts at installing
and reinstalling, the results are still the same. The total amount shows 0.00$.
Price alert does not work at all and gives me a connection error. The wallet
simply refuses to fetch price updates despite many attempts. Hope the Trust
Wallet community can help me out. Thanks.


To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

1 Like

1 Like

Hi there,

My apologies for flagging your post earlier. I had to be careful. Hope there aren’t any hard feelings.
Anyway, I have shared my details below. And the screenshots are there too.




Hello @ygs26480
No problem, it is best to always be extra careful.
Regarding your token not showing a value, please read this below:

1 Like

I accept your argument. However all the coins in the screenshot do not show values at all.
Even Bitcoin, BNB, Ethereum etc show no price at all. Is that not strange? Check out all
my screenshots shared. The prices of these tokens were all showing up earlier and I faced
no issues whatsoever.

It’s just been a week since these issues have started taking place. If you guys could only ensure
that the tokens are able to fetch the prices by connecting to the exchanges, then I am sure all will
be fine.

1 Like

What device are you using?
Please provide your app version and if possible a video recording of this issue.

1 Like

I am unable to provide a video recording. But I am using Trust Wallet version 5.0

Check the screenshot in this message. The price alerts on my wallet does not connect to the exchanges. It always says ‘An unknown error occured’. TRY AGAIN

What is your device name?

I have a Sony Xperia XA1 ultra on me. That’s the android device that I use everyday.

Hey @ygs26480
Can you try using a VPN to access your wallet if that fixes the issue ?
Also what Country are you from ?

Hi there,

My Trust Wallet has started working again. Price details are being updated regularly on all the tokens in the wallet. I guess whatever you did at your end worked. Thanks for all the help.

1 Like

Glad that worked out well