My Trust wallet not loading in Uniswap

Hi there, i tried to link my trust wallet with uniswap but it seems like its not working. I tried re-importing my wallets, delete and add my wallet again. Restart my phone but all these seems like its not working.

It just kept loading…
Please help.

1 Like

Exact same issue as you.
On iPhone, Trust Wallet app version is 5.19 (5194).

Yup… and we not getting any help or support … such a disappointment

I notice only my ethereum network is forever loading. How to solve this issue can someone help ? I tried deleting installing the app

Same issue here. The eth network didnt work in any site. The BSC network is working well.

My other wallet with other Brand its working well in eth network.

Good to know it’s not effecting the other chain protocols. I’d be interested to hear about how we can get the Ethereum chain working again.

Hi @Axenlee, @felipetorres, and @Needhalppls,

Have you tried to use a VPN? Perhaps, re-install as well?

No, I haven’t tried a VPN. Never had to use one before.

Yes, tried a clean reinstall.

As a special note, I’m having difficulty using Trust Wallet on the Ethereum chain with Uniswap on almost any platform. Browser based (Chrome, IE, and Firefox) among my laptop and desktop.

I didnt try it but in other wallet brand the eth network is working well, so why the VPN is necessáry to Trust wallet?

This might solve your issue:

Some apps were crashing for Android users, but Google has fixed it. The issue was due to a system component called Android System WebView that lets Android apps display web content. Google now has a fix that requires users to update Android System WebView to version 89.0.4389.105 and Google Chrome to the latest version. Both are available on Google Play.

I m using IOS :pensive:. I think that no relation with google because my other wallet use chrome and work normally.

@Needhalppls and @Axenlee, what is your Trust Wallet app version now? (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

Hello There. If u can not join uniswap at first time, please go out and enter second time. Everything will be ok.

1 Like

Glad it works for you @Mikhailkola.
@Needhalppls, @Axenlee, and @felipetorres, please try the mentioned fix.

The dev team tried to replicate the issue but there are no errors. That being said, you may also want to try using a VPN, as there might be interference with the connection.

The version is: 5.19 (5194)

The “fix” listed above isn’t one. I and Axenlee have deleted and then reinstalled the application is what we are saying and are still having the same issue. I have force quit the application and am still having the same issue. Before this started about 3-4 days ago I had used Uniswap through the Dapp nearly 20 times with no issues and never using a VPN. The issue is connected to the wallet as well because when I attempt to use Uniswap on a desktop or laptop browser Trust Wallet has issues staying connected, and then fulfilling transactions.

Were you using WalletConnect? Use the DApps browser instead. Here’s a guide on how to enable it:

It’s been enabled… when I referred to the dapp that’s what I was talking about… I’m having the exact same issue pictured by Axenlee…

Can you try to use As mentioned by the dev team, it should be cheaper and faster to swap for now. They will also look into making improvements next week if something could be done on their side.

Now my etherium network is working well. Thank you for all support. :rocket::rocket:

1 Like

Same problem on Ios 14.4.2. Uniswap through dapp doesn’t show any balance for ETH on mobile and won’t connect via wallet connect on pc. Any update for this problem?