Need help BUSD funds not showing

Hello, iv sent busd to my trust wallet. It appears in the wallet then disappears. When I go to try and swap or send it it shows my balance but then disappears on and off. when I go to confirm it says I have a balance of 0??

Help would be greatly appreciated, Thanks!

Hello @Mrcornect To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

I Have issue my coins was dissapear from Wallet and appear again l, whats going on?

Thanks for the reply, I believe I accidentally sent busd to my bnb smart chain wallet. As you can see it funds show then disappear. I was trying to send BUSD from binance to BNB smart chain to purchase tokens on pancake swap.

Heres my transaction hash:

Hi, please tap on top right corner and search BUSD then switch on BUSD BEP20 manually. This guide can help too: How to Add or Remove a Coin

I have done that still having the same problem

@Mrcornect but your BUSD is already displaying in your wallet. From transaction hash you sent above, your address received 399.11517245 BUSD and that’s what you have.

As you can see I refresh the page multiple times then my funds show but as soon as I click swap or trade or anything it disappears and says I dont have enough to pay for the 0.31 gas fee which im suppose to have 399 BUSD

Sorry for spam, appreciate you Alan.

Still no solution, it appears and disappears when when I click on it to trade or withdraw says I have 399 as soon as I click on it goes to 0 and says I have no balance . Wtf

Im aware but when I go to do anything, withdraw, swap, etc, it disappears and says I have 0 funds. I cant use it?

1st… you need to have some BNB BEP20 (Smart Chain) to cover your transaction fees. Read more about fees here: Cryptocurrency Network Fees

2nd… about assets disappearing, can you record a video showing how it occurs and upload it to Google drive then share public link here?

@Mrcornect your video link is not public. Make it public so as we can access it.

And alan I just purchased 50$ Of busd to see if it would work and Im having the exact same problem I cant withdraw anything or swap anything.

Sorry i wasnt aware you should be able to view it now let me know, thanks a lot.

@Mrcornect I was able to open the link. But before I report this issue to the team, try to re-import your wallet and check if problem will resolve.
Here’s a guide: How to Re-Import your Wallet

I just did that, deleted/recovered the wallet and disabled all tokens and re enabled them as well and still showing 0 funds.

@Mrcornect can you check now? Our team has worked on this issue and has been resolved.

Thank you ! my funds are now there. Problem resolved.