Need Trust Wallet update for Samsung galaxy j2 Android version 5.1 Lollipop

hello I…am. Trust Wallet user . My phone Samsung galaxy j2 Android version 5.1 Lollipop please update Trust Wallet apps wallet MY account please help me

4 Likes

Are you saying it doesn’t work on your phone no longer try upgrade your andriod version or get a latest phone with much recent andriod version.

1 Like

Hi @Ariff,

Please be informed that the app requires Android 6.0 and up. Check for Android updates and install them by following this guide: Check & update your Android version - Android Help. For custom tutorials on how to install the latest Android version, you can search on Google.

1 Like