Pending and failed txs

Hello there Alan, I have the same issue as the Thread Starter.

I also have re imported my wallet but the issue still not resolved. Can you help me with this?

Hello @setasiunbalapan To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)


I tried to send BUSD to another wallet but it always pending and turned to failed. It is also the same when I tried to make smart contract call

Hi @setasiunbalapan,

Chiming in, is the issue that you encountered recently got resolved?

still not resolved, I haven’t been able to send or to make a smart contract call until now

Please try a full reinstallation of the app.

Make sure you have a backup before you proceed.

Uninstall and then reinstall your app.
Follow this guide to restore your wallet.

Thank you very much, I tried this solution and it works now! Now I can transfer my assets to another wallet. Cheers!

Awesome! Glad to know that~

If you encounter any new issues or if there is something that you want to clarify feel free to click the “New Topic” button to create a new one.

I’ll lock this topic to prevent thread hijackers so that anyone who encounters the same problem can follow this smoothly.

Cheers and see you around!~