Pending Transaction .. Tried cancelling it out then the first one just disappeared

I have send my eth from coindirect to my trustwallet and then tried to join forsage and my transaction was pending for about a day (I did it on 29 June 2020 and last night 30 June 2020 it was still pending) (First photo is where the first tansactions was still pending) so I tried to cancel it out with the instructions by creating a new transaction send 0 eth in to my trustwallet and then my first transaction disappeared but the new one is still pending the one with the 0 eth … (Send photo is where it just disappeared)

Is my transaction cancelled or what happend with it why did it just disappeared?
What can I do I would really like to get started with forsage ASAP please

To better assist, can you provide us the following information:

  1. Trust Wallet app version
  2. Crypto address
  3. Transaction ID (if you have any)

You can also do the following steps:
Are the pending transactions showing anything when you tap on More Details?
If Yes, follow this guide: Pending "Stuck" Transactions
If No, use this one: How to Re-Import your Wallet

I have the same problem.
app version: 1.21.4
please help me. I did everything you said and nothing is working.

Hi @sajadszm

Your fee per byte is very low: 0.637 sat/B. You need to wait for the Bitcoin miners to confirm your transaction.

– Locking the thread since this is an old one and your question is already answered. Feel free to create a new thread if necessary.